Page 4 of 5

Re: Windows 10 Pro with RTK XI

Unread postPosted: Mon Jan 18, 2016 7:29 pm
by Prince Aladdin
I am using the standard Windows 10 Home edition.

The VM I am running is the latest version of VirtualBox.

Re: Windows 10 Pro with RTK XI

Unread postPosted: Mon Jan 18, 2016 9:07 pm
by Teh Zhuge
Hmm, I don't remember that Direct X should be working natively for a guest operating system with Virtual Box; that's why Hyper-V doesn't work out at all, at least not for the non-server versions of Win 10. Virtual Box has a work-around by using the Windows 10 host system, though be aware that it can be a security issue; I only play the game on the guest system and get files through the host system, not directly from the internet to the guest system, and so I'm not worried about that. Have you installed the Guest Additions? Are you aware of that documentation for the work-around?

https://www.virtualbox.org/manual/ch04.html

In Ch. 3.5 before that in the manual, it explains that Guest Additions needs to be installed to enable 3D acceleration, which means DirectX.

It's been awhile since I've done it. Let me know if you still can't figure out, or if you have already tried the Guest Additions.

Re: Windows 10 Pro with RTK XI

Unread postPosted: Mon Jan 18, 2016 9:33 pm
by Prince Aladdin
Before I continue, I want to thank you for your help Teh Zhuge. Hopefully we can figure this out and get it working because I'm not too tech savvy and have pretty much reached my limits.

Alright, onwards then. Yes I have installed the Guest Additions. I have enabled 3D acceleration from the settings menu in VirtualBox as well. I also tried reintalling Guest Additions in SafeMode as per the manual, but it still has not fixed the DirectX error.

Edit.

So after playing around a little bit more, I have managed to get the drop down menu to allow me to select a resolution, and there is no longer a DirectX error when I launch the settings tab. However, the game still does not start. There is some error message in another language that I cannot understand.

I managed to get the game to open once. The translation patch did not fully translate (or at least not as much as I had previously remembered), so I closed the program down and when I attempted to reopen it, it would not launch. It is giving me the same error message every time, but I cannot understand the message. I am trying to run the PUK by the way,

Re: Windows 10 Pro with RTK XI

Unread postPosted: Tue Jan 19, 2016 12:27 am
by Teh Zhuge
Prince Aladdin, it's been a few months and I just tried to use the VM. I had to put in my product key since I hadn't gone through that before, and my desktop background ended up black for some reason. When I tried to open up the PUK, I got that weird error box that has a string of apparently random characters--a familiar message box for me by this point.

I don't really have the time and inclination to go through the effort of working that out, since I am not playing. However, I will try next week or the week after.

At this time, I would suggest that you look at Gray Riders' earlier post, and follow that link. That is what I will be doing when I get time for it. Because the KB update affects Win 7, it should even affect a Win 7 running on a VM, as Lezard Valeth pointed out. I did have everything working before, but after I put in the product key everything updated and now it seems I can't run it. So I'm guessing it's because of that update.

Good luck with it for now. I'll be back next week or the week after with an update on my own efforts.

Re: Windows 10 Pro with RTK XI

Unread postPosted: Wed Jan 20, 2016 7:20 pm
by Prince Aladdin
Ah yes, that error message. No way to know what it is trying to tell us. If only we did, we could have somewhere to start working from.

Do not worry. If you have the time to lend me a second set of hands on this project, that would be a welcome addition. I am desperate to play this game again, so I will keep on trying to get it running until I burn out or they release a better RoTK (not a fan of 12 or 13 by the looks of it). I am also busy so it will be a slow process.

Gray Rider's post holds merit for this discussion of Windows 7. However, Windows XP on a VM holds the same failed error message as the one on a Windows 7 VM. I am attempting to resurrect the game on a Windows XP VM because I have been able to make more progress in that platform. I got the game running at least once, but after that it never started up again.

Good luck to you as well, my friend.

Re: Windows 10 Pro with RTK XI

Unread postPosted: Mon Feb 01, 2016 9:40 pm
by Lu5ck
You can't play ROTK 11 PUK JP + Translation with Windows 10 anymore.
Windows 10 has ceased support for SafeDisc and SecuRom.

You will need a patched exe to run the game but if you do use the patched exe, the translation patch won't work because it is not based on that exe.
You will have to install Windows 7 to use the translation patch or if you are able to read chinese, the chinese version has a patched exe.

This is what I learn after spending an hour trying to get it working =,=

Re: Windows 10 Pro with RTK XI

Unread postPosted: Tue Feb 02, 2016 12:34 am
by Teh Zhuge
Lu5ck, please read the previous posts. We are well aware of the Securom/SafeDisc problem. That is why the VM ware has been put forth as a solution, and also why I referenced Gray Rider's post. It turns out that Securom/SafeDisc is now also a problem for Windows 7, and the possible solution for it is referenced by Gray Rider. Anyone who is trying to use the VM ware solution and uses Windows 7 as a guest operating system will need to go through that solution, if their Windows 7 is updated.

I haven't yet gone through the effort of fixing my Windows 7 installed as a guest system, so I cannot comment on the efficacy of Gray Rider's solution yet.

Re: Windows 10 Pro with RTK XI

Unread postPosted: Wed Feb 03, 2016 3:32 pm
by Lu5ck
I did read that but also pretty sure no one mentioned that the chinese version has a patched exe.
With that said, also pretty sure that no one mentioned that none of the translation patch will work because it is based on the old exe so even if anyone found a patched exe for their japan version, it will not work with translation patch.

I wonder if anyone will port the translation patch to the patched exe for the chinese version?

Re: Windows 10 Pro with RTK XI

Unread postPosted: Sat Feb 06, 2016 12:24 pm
by Teh Zhuge
Lu5ck, your initial post strongly suggested that you had not read the previous posts, since the first two lines of your post were already discussed at length.

By "patched exe", I take it you mean the no-CD crack. I mentioned that in an earlier post.

I will also point out that it has already been explained in previous posts that using an earlier Windows operating system is necessary; and that anyone using Win 10 will have to use virtual machine (VM) ware in order to play the game using Win 10, by having an earlier Windows operating system set up as a guest operating system through the VM ware.

Our current problem (for those of us who are trying to work with Win 10) is that because of an update to Windows 7 and 8, it is unclear whether even the VM ware option will work now; and Prince Aladdin is saying that he cannot even get the game to work for Windows XP now on the VM ware. I have yet to investigate into the proposed solution of it offered by Gray Riders, so I cannot comment yet on the viability of the proposed solution; I am very busy with work these days, and I suspect I will not get it to now for a couple months at least.

If you discover some kind of breakthrough, please let us know.

Re: Windows 10 Pro with RTK XI

Unread postPosted: Sat Jun 11, 2016 11:16 am
by heirtothestar
Have anyone here try Driver Signature Enforcement Overrider http://www.ngohq.com/?page=dseo to self sign secdrv.sys and run the game ?